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Trademark 
C5100B BatteryStore is a trademark of Cadex Electronics Inc.  All other trademarks or 
registered trademarks mentioned herein are the property of their respective owners. 

Copyright Notice 

Copyright © 2016 by Cadex Electronics Inc.  All rights reserved.  No part of this 
publication nor the software and/or firmware controlling Cadex product(s) may be 
reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any 
language or computer language in any form or by any means without the express 
written permission of Cadex Electronics Inc. 

Revision Rights 

Cadex Electronics Inc. reserves the right to revise this publication and make changes in 
the contents thereof without obligation to notify any person of such changes.  Please 
contact Cadex Electronics Inc. (service@cadex.com) for suggestions or corrections. 

Disclaimer 

While every effort is made to ensure that the information contained in this manual and 
Online Help is accurate and up-to-date, Cadex Electronics Inc. does not warrant or 
guarantee the accuracy of the contents of this manual and Online Help.  Further, Cadex 
makes no warranties, either expressed or implied, as to the merchantability or fitness for 
a particular purpose of the C5100B BatteryStore Software and/or its documentation. 

In no event will Cadex or its officers or employees be responsible for any consequential, 
incidental, or indirect damages (including damages for loss or business profits, business 
interruption, and the like) arising out of the use or inability to use the C5100B 
BatteryStore Software and/or its documentation. 

To obtain service, contact service@cadex.com or visit the Cadex website 
www.cadex.com/contact-us/cadex-electronics  for up to date information. 
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Section 1: Get Started with 

BatteryStoreTM 

Welcome to BatteryStoreTM 
BatteryStoreTM is Microsoft Windows-based software that lets 
users start and monitor battery tests on a C5100B and stores 
battery test result histories in a database. 

BatteryStore can export test data, consolidate tests, provide test 
reports, and generate performance summaries. BatteryStore also 
provides the ability to print receipts and customize service 
reports. 

PC Mode (Tethered Mode) 

 

The PC with BatteryStore is used for: 

a. C5100B Control (Test, Charge, or Cycle) 

o QuickSort™ Test 

o QuickSort™ 3.0 (QSMS) Test 

o QuickSort™ 4.0 Test 

b. Data Management: Store and export test results 
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c. PC or Network Printing: Prints a test report 

d. Optional Receipt Printing: Prints test results on a 2.25” 
[57mm] wide receipt 

How to setup up PC Mode:  

1. Connect hardware according to the PC Mode diagram 

2. Configure BatteryStore Options (Section 4) 

a. Site information 

b. Printer Setup 

c. Report template 

 

The BatteryStore Software Package 
The Cadex C5100B BatteryStore software package contains the 
following items: 

 Cadex C5100B BatteryStore Software 

 BatteryStore Installation  Guide 

 

Computer Requirements 
BatteryStore requires the following computer configuration: 

 Windows 7, 8, or 10 

 1.2 GHz or faster CPU 

 512 MB RAM 

 PC with USB port 

 An SVGA color monitor 1024 x 768 or better, 256 colors 
minimum; mouse & keyboard 

 

Receipt Printer Compatibility 
The C5100B can be configured to print test results on a 2.25” 

[57mm] wide receipt. The C5100B and BatteryStore are 

compatible with the Bixolon STP-103 III thermal printer (sold 

separately). 
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Receipt Printer Installation 
The Bixolon STP-103 III thermal printer requires the following 
installation steps. 

1. Connect DB9 Male-to-male Adapter into the C5100B serial 
port (back of device) 

2. Set the DIP switches on the Bixolon STP-103 III thermal 
printer: 

a. Serial Interface settings 

Baud rate: 9600 bps 

Data bits: 8 bits 

Parity: None 

Stop bit: 1 bit 

The serial interface settings are required in order for 
the C5100B to correctly communicate with the thermal 
printer. See figure below for printer underside. 

 

3. Follow the Printer Installation Guide that is included with the 
Bixolon STP-103 III thermal printer 
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Install BatteryStore 
To install BatteryStore: 

1. Download the latest version from the Cadex website: 

http://www.cadex.com/en/subscriptions 

Password: victoria 

The download is a compressed executable file (with file 

extension .MSI) 

2. Open the folder where the downloaded file was stored and 
double-click BatteryStore.msi to install BatteryStore. The 
Welcome to Cadex BatteryStore Setup Wizard window 
appears. 

3. Follow the steps through the installation wizard 

 

Uninstall BatteryStore 
To remove BatteryStore from your computer: 

1. In Control Panel, go to Uninstall a program 

2. Select Cadex BatteryStore and click Uninstall 

 

Software Updates 
To see which version of BatteryStore is installed on the computer, 
select About from the Help menu.  The BatteryStore version 
appears in the About window.  

Update BatteryStore Software 
When a new version of BatteryStore becomes available, it can be 

downloaded from the Cadex website:  

http://www.cadex.com/en/subscriptions 

Password: victoria 

The download is a compressed executable file (with file extension 

.MSI) 

 

Running the downloaded executable will either run Setup and 
install a new version of the software, or extract files to a specified 
directory.  

http://www.cadex.com/en/subscriptions
http://www.cadex.com/en/subscriptions
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The Menu Bar 
BatteryStore Main window displays a title screen, a menu bar, 
and a C5100B status bar. 

 

The menu bar on BatteryStore Main window displays six menus:  
File, Test, Results, Options, C5100B Setup, and Help. By clicking any 
of these menus displays a list of menu commands. 

File Menu 

The File menu contains two items, as follows:  

Connect: Establishes communication between C5100B and PC 

Exit: Select Exit to close BatteryStore 

Test Menu 

Click Test to test a battery on a C5100B. 

Results Menu 

Click Results to view battery test results. 

Options Menu 

Click Options to specify site information, printer setup, report 
template fields, battery models information and database 
maintenance options. 
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C5100B Setup Menu 

Click C5100 Setup to write and read the C5100B configuration, 
including the receipt printer settings.  

Help Menu 

The Help menu contains two items, as follows: 

Help Content: Click Help Content to view this manual 

About: Click About to view the About window 

 

Connect a C5100B to the PC 
To connect a C5100B to the PC: 

1. Connect one end of the USB cable to the PC 

2. Connect the other end of the USB cable to the backside of 
the C5100B 

 

Connect a C5100B to BatteryStore 
 

 

 

 

 

Select Connect from the File menu to connect a C5100B to 
BatteryStore.  The Connecting to C5100 window appears. 

 

If the connection was successful, the C5100B is listed on the C5100 

Status bar. 

           NOTE 

BatteryStore automatically connects to a C5100B when 

BatteryStore starts up. 
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Exit the BatteryStore Application 
To close the BatteryStore application: 

o From the File menu, select Exit 

 Or 

o Click X at the top-right corner 

 The Exit window appears. 

 

Click Yes to exit BatteryStore. 
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Section 2: Test, Cycle and 

Charge Batteries 

Perform a Battery Test 
 
 
 
 
  
 
 
 
 
 
 
  
 
 
 
 
 

To perform a battery test, click the Test menu item. The 
Battery Test window appears. 

 

Battery Test Methods 

Test Performs rapid battery tests using Cadex’s QuickSort™ 
Technology. 

Charge Charges a battery. Approximately 3 hrs. 

Cycle Cycles a battery with charge/discharge/charge and 
displays measured capacity as a percentage of the Q-
Code/C-Code capacity rated value. Approximately 7 

           NOTE 

Test results are retained on the C5100B until a new test is 

initiated. Therefore, additional copies of receipts can be 

printed without running the test a second time. 

The result from a test, cycle, or charge is automatically 

saved in the Results Section. 

           WARNING 

Do not remove the C5100B battery adapter while the 

C5100B is running a test or updating the firmware. 
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hrs. 

A battery test contains the following steps: 

1. Select the battery’s nominal voltage 

2. Select the battery’s nominal (rated) capacity 

3. Run a battery test 

4. Print the receipt or test report 

Step 1: Select the Battery Model 
The Battery Test window provides two methods to select a 
battery model:  

o User Specified Rating: Input the nominal battery 
capacity mAh in the field (this information should 
be located on the battery label). This method 
triggers either QuickSort™ (below 1400mAh) or 
QuickSort™ 4.0 (1400mAh or above). 

Or 

o Select Battery: Select a battery model from the list. 
If your battery model cannot be located, use the 
other option. This method triggers QuickSort™ 3.0 
(QSMS), if available. 

In the Select Battery option, click Select Battery button. The 
Battery Models window appears. 

 

In the Battery Models window, click the DOWN ARROW in the 
Manufacturers field to view a list of battery models 
manufactured by a specific company. 
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The Battery Models window lists all available battery models. 
For each battery model, the window shows the manufacturer’s 
name, the battery’s model number, the rating, nominal 
voltage, the alias, and the QS3 model, if applicable. To set a 
specific battery model as a “favorite”, select the check box in 
the Favorite column. To view only those battery models 
selected as favorites, select the Show Favorites Only check box. 

 

Show QS3 Models Only lists all available QuickSort™ 3.0 
(QS3) battery models. For each battery model, the window 
shows the manufacturer’s name, the battery model’s number, 
the rating, nominal voltage, the alias, and the QS3 model. To 
view only QS3 battery models, select the Show QS3 Models 
Only check box. 

           NOTE 

You can update the list of battery models by entering new 

models or downloading an updated database from the 

Cadex website (see Update and Backup the Battery Models 

Database). 
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Step 2: Run a Battery Test, Charge, or Cycle 
In the User ID field, type an identification code for a customer 
or employee. Type any notes in the Service Notes field, as 
required. To test the battery, click Test. To charge the battery, 
click Charge. To discharge and then charge the battery, click 
Cycle. 

The Test Status field indicates the status of the test:  

 A progress bar is used to show the progress of the 
current test 

 A Cancel button is used to halt the test 

 Finish – the test has completed. 

The Test Log field contains additional information about the 
test status and test result. 

Step 3: Print the Receipt or Test Report 
BatteryStore prints receipts on a standalone receipt printer 
and test reports on a PC printer. Configure the default printer 
in the Options->Printer Setup window. 

1. Standalone Receipt Printer 

Go to C5100 Setup to configure receipt printer. (Note: To 
activate Receipt printing, ensure the C5100B printer is not set 
to disabled). 

2. PC Printer 

Go to Options->Printer Setup to configure PC printer. 

_______________________________________________________ 

The Print button prints to the default printer. 

The Auto Print Test Report option automatically prints the test 
report or receipt when the test is completed – you do not need 
to click Print. 
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Section 3: Manage Test Results 

Manage Test Results 
The Test Results window lists all battery test reports. For each test result, the 
Test Results lists: 

 Test number, test type, and test result 

 Start and end date & time of test 

 Battery manufacturer’s name and battery model 

 Fault code, if any 

 Capacity rating, voltage rating, and equipment ID 

 C5100B firmware revision number 

You can view and print test reports, export a test report to a comma-delimited 
text file, save the test report as a PDF file, view a summary, or delete the test 
report. 
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View Test Results 

To view a test result, click the Results menu item. The Test 

Results window appears. 

 

Highlight a test result and click View. The test result appears 
in the Service Report window. 

 

To print the test report, click Print. To save the test report to a 
PDF file, click Save. 
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Print Test Results 

To print a test result, click the Results menu item. The Test 

Results window appears. 

Click the check box in the left-hand column to select a test 
result and click Print. The report is sent to the default printer. 
Multiple test reports can be printed by left-clicking multiple 
test results. Click the Select/deselect all check box to quickly 
select or deselect all test results. 

 

Export Test Results 

To export a test result to file, click the Results menu item. The 
Test Results window appears. 

Select the check box adjacent to each test result to export and 
click Export. The Export Report Data window appears. 

 

In the File Name field, type a name for the report and click 
Save. The report may be saved with an Excel (.xls) format or 
comma separated value (.csv) format. 
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Save Test Results 

To save a test result, click the Results menu item. The Test 

Results window appears. 

Select the check box adjacent to the test result to save and click 
Save As.  The Report Save As window appears. 

 

In the File Name field, type a name for the report and click 
Save. The test result report may be saved in PDF (.pdf), HTML 
(.html), and text (.txt) file formats. 

 

Delete Test Results 

To delete a test result, click the Results menu item. The Test 

Results window appears. 

Select the check box adjacent to test result to delete and click 
Delete. The Delete Test Result window appears. 

 

Click OK to permanently delete the selected test results. 
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Search for Test Results 
The BatteryStore database may contain hundreds, or even 
thousands of test results.  The Search section of the Test 

Results window lets you search for specific test results. 

 

To search for results based on the battery manufacturer’s 
name, the battery’s model, or by the test result (good, fair, 
poor, or low battery), click the DOWN ARROW in the 
appropriate field and select the criteria.  

To search for results based on a date, deselect the All check 
box and then click the DOWN ARROW in the From field.  Next, 
click the DOWN ARROW in the To field and select the ending 
date. 

Click Apply to search for the test results. 

 

Sort the Test Results 
To sort the test results, click the Results menu item. The Test 
Results window appears. 

To sort the test results, click the column header. The test 
results are sorted in ascending order. Click the column header 
a second time to reverse the sort order. 
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View a Test Summary Report 
To view a summary of test results, click the Results menu 
item, then click the Summary button. The Report Summary 
window appears. 

 

 

The Report Summary window shows a breakdown of all the 
tests that were performed.  

 
 
 
  
 
 
 
 

 

 

View different Result summaries by clicking the DOWN ARROW 
in the Result Type field and selecting between All, Test, 
Charge, and Cycle. 

           NOTE 

The Report Summary will only display test results that are 

active in the test results window. For instance, to view the 

Results Summary for a specific Battery Manufacturer or 

for a specific time, apply the Search tools (Search for Test 

Results section) to modify the list of test results. 
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Section 4: Configure 

BatteryStoreTM Options 

BatteryStore Options 
The information in the Site Information Setup window 
appears in Test reports and is the default information that 
appears in the C5100 Setup window.  

To configure BatteryStore’s options, click the Options menu 
item. The BatteryStore Options window appears. 

 

The General tab contains Site Information, Printer Setup, and 
Report Template option settings. The Database tab contains 
Battery Models and Maintenance option settings. Click the 
appropriate tab to see the list of options.  
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Site Information Setup 

BatteryStore can save customer site information. For each site, 
BatteryStore saves the site ID, company name, address, and 
contact information. 

To manage site and contact information, click the Site 

Information menu item under General tab. The Site 

Information Setup window appears. 

 

The default customer site’s information appears in the Site 

Information Setup window. If required, type new information 
about the customer’s site in the appropriate fields and click 
OK to save the information. 

Create New Site Information 
To create new site information setup, click New. A blank Site 

Information Setup window appears. 
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Type the information in the appropriate fields for the new 
customer site. Click OK to save the information. 

View Site Information 
To view information about a specific site, click Select Site. The 
Select Site Information window appears. 

 

The Select Site Information window lists the sites in the 
database. Select the site to view and click OK. The site’s 
information appears in the Site Information Setup window. 

To delete a site, select the site and click Delete. 

Export Site Information 
Information about each site can be exported to a Site 
Information file. To export the site information, click Export. 
The Save As window appears. 

 

Type a name for the site information file in the File name field 
and click Save. The site information is saved to the file in 
(.xml) format. 
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Import Site Information 
Information about sites can be imported into BatteryStore 
from a Battery Customer Site (.xml) file. To import the site 
information, click Import. The Open window appears. 

 

Locate the text file that contains the site information and click 
Open. The site information is imported into BatteryStore’s site 
database. 

 

Printer Setup 

To configure printer setup, click the Printer Setup menu item 
under the General tab. The Printer Setup window appears. 

 

In the PC Printing Options section of the Printer Setup 
window, select the printer to use by clicking Change. The 
Print window appears. 
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Select the appropriate printer BatteryStore will use to print 
test reports and click OK. 

Click the DOWN ARROW in the Print Mode field and select the 
printing mode.  Select the Manual option to require the user to 
click Print on the Test page to manually print the test report 
when the battery test is completed; select the Auto option to 
print the test report automatically when the battery test is 
completed. 

In the Default Printer section of the Printer Setup window, 
select the C5100B Printer or the PC Printer option to select the 
printer that BatteryStore will use to print. 

 

Test Report Template 

To specify the fields that will appear on printed test reports, 
click the General tab and then click Report Template. The 
Report Template window appears. 

 

By default, all field names are automatically selected. Clear the 
check box next to a field’s name to exclude that field from the 



 Cadex C5100B BatteryStore™ v1.6 User Guide 

 2016 Cadex Electronics Inc.        27 

report. Select the check box next to the field’s name to include 
that field in the report. To select all field names, select the 
Select/deselect all check box; to remove all field names, deselect 
the Select/deselect all check box. 

To move the position of a field up or down in the report, click 
the field name and then click Move Up or Move Down. This 
sets the order that the fields will appear in reports using this 
template. 

When you have finished selecting the fields for the report 
template, click OK to save the template.  

To print a company logo on the report, click Browse.  The 
Select Report Logo window appears. 

Logo files can be JPG or BMP files. Navigate to the folder that 
contains the logo file, select the file, and click Open. The logo 
file’s image appears in the Report Logo section of the Report 

Template window. 

When you have finished selecting the options for the report 
template, click OK to save the template. 
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Section 5: C5100 Setup 

C5100B Setup 
The C5100 Setup window is used for target capacity, receipt 
printing and firmware update. A user can assign desirable 
target capacity and print mode onto the C5100B or read 
settings from the C5100B by clicking Refresh buttons. 
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Target Capacity 

The new firmware has adjustable user defined target capacity. 
All QuickSort™ 4.0 test and Cycle results will display Good or 
Poor based on this setting. 

To configure Target Capacity setting, choose one of following 
options: 60%, 70%, 80%, or 90%. 

Click Set to save the Target Capacity setting or click Refresh to 
retrieve the C5100B’s current Target Capacity setup. 

 

 

C5100B Printer Setup 

The information in the C5100 Setup window is used when 
printing receipts from a network printer or the Bixolon’s 
thermal printer. 

To configure the receipt printer information, click the C5100 
Setup menu item. The C5100 Setup window appears. 

In the Equipment ID field, type identification numbers or 
alphabets (up to 10 characters) to associate with the selected 
C5100B. 

Click the DOWN ARROW in the Print Mode field and select the 
printer option, as follows: 

 Disable: The default printer will not be used. 

 Manual: When the battery test is completed, click Print 
on the Test page to manually print the test receipt. 

 Auto: When the battery test is completed, the test 
receipt is automatically printed. Additional receipts 
can be printed by clicking the Print button. 

Click Set to save the Print Mode setting or click Refresh to 
retrieve the C5100’s current Print Mode setup. 
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In the C5100 Printer Setup section of the C5100B Setup 
window: 

 The Site Information window under Options should 
be filled out first as this information is automatically 
transferred to the C5100 Setup window by default. 
Click Update to save the information to the C5100B. 

 The date and time information shown in the PC are 
automatically sent to the C5100B for printing in stand-
alone mode. 

 

Firmware Update 

The FW Version field displays the version of the firmware 
installed in the connected C5100B. Select the Update button 
and follow the Firmware Utility directions to upgrade the 
firmware. 

Note: During connection, BatteryStore identifies if your  
C5100 is an older version (see figures below). Update the 
C5100B firmware using Cadex C5100 Firmware Utility to 
ensure correct operation of BatteryStore. 

BatteryStore first opened: 
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Trying to operate the C5100B in BatteryStore: 

 

 

To update the C5100’s Firmware: 

1. Select Update from the Firmware Update section. 

 

2. Click OK to update the firmware or Cancel to return to 
the C5100 Setup window. 

3. Cadex C5100 Firmware Utility window appears. 
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4. Click the DOWN ARROW in the Port to connect to field to 
select the COM port that the C5100B is connected to. 
Ensure AC power is applied to the C5100B and USB 
cable with a Type B connector is connected from the 
analyzer to the computer.  Click Search. If there is a 
working connection, the firmware information 
appears. 

5. Click Browse to select a firmware file (firmware files 
have a file extension .sef) and click Open. 

 

6. Next, click Update to initiate the firmware flash 
process. The Confirm window appears. 

 

7. Click Yes to update the firmware. 
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8. The Information window appears when the firmware 
has been updated. Click OK. 

 

9. Click Exit. The Confirm window appears. Click Yes to 
exit the firmware utility. 

 

10. Close BatteryStore and restart the software. 

 

 

 
If error messages occur, contact Cadex Technical Support at 
(Canada) 1-604-231-7777, (USA Toll Free) 1-800-565-5228, or 
(Europe) +49 (0) 6105 975 11-0, or service@cadex.com.

           WARNING 

Do not remove the C5100B battery adapter while the 

C5100B is running a test or updating the firmware. 
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Section 6: Update and Backup 

the Battery Models Database 

Battery Models and Q-Codes Update  

To Update the Battery Models database and Q-Code Library: 

1. Open BatteryStore. Select Options. Select Battery Models 

under Database.  

2. While still in the Battery Models Update page, select either 
Add new models only or Add new models and update existing 
models. Select Web Update. 

 

3. The Update Battery Models window appears. 
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4. Click OK to update the database or Cancel to return to the 
Battery Models Update window. 

5. Click Stop to cancel the process anytime. 

6. The number of battery models that were updated and the 
number of battery models that were added will be shown 
below. 

 

7. Click OK to return to the Battery Models Update window. 
Next, click OK return to BatteryStore’s active window. 

 

The following steps are only required if you do not have 
access to the internet. This method requires a database file 
which can be obtained from:  

http://www.cadex.com/en/support/technical 

 To Update the Battery Models database and Q-Code Library: 

1. Save the .CFG database file to your PC. The .CFG file is 
found on the Cadex website, under Technical Support. 

2. In the Options menu click the Battery Models menu item. 
The Battery Models Update window appears.  

http://www.cadex.com/en/support/technical
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3. To select the file that contains the battery models database 
file, click Browse. The Select Battery Models 

Configuration File window appears.  

 

4. Select the configuration file (configuration files have a file 
extension .CFG) and click Open.  

To add battery models that do not exist in the database, 
select the Add new models only option; to add battery 
models that do not exist in the database and to overwrite 
existing models, select the Add new models and overwrite 
existing models option. Click Update.  

5. The Update Battery Models window appears. 
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Click OK to update the database or Cancel to return to the 
Battery Models Update window.  

6. Click Stop to cancel the process anytime. 

7. The number of battery models that were updated and the 
number of battery models that were added will be shown 
below. 

 

8. Click OK to return to the Battery Models Update window. 
Next, click OK return to BatteryStore’s active window. 

 

Backup the Battery Models Database 

BatteryStore can automatically backup your battery models 
database. To specify the frequency of the backup procedure, 
select Maintenance under Database. The Database 

Maintenance window appears.  

 

The backup copy of the battery models database is stored by 
default in the C:\ProgramData\Cadex\BatteryStore folder. To 
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change the location of the backup file, click Browse and 
choose a different folder. 

Click the UP or DOWN ARROW in the Frequency field to select 
how many days should pass before the backup procedure is 
executed.  

Click OK to save your maintenance settings. 


